Box trouble (including Box Sign, Box Notes)

Incident Report for Tufts University

Resolved

Box reports that this issue is resolved. If you continue to have difficulty with Box (uploads, downloads, Box Sign, Box Notes), please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Oct 02, 2023 - 15:00 EDT

Monitoring

Box has implemented a fix and are monitoring the results.
Posted Oct 02, 2023 - 14:03 EDT

Investigating

Tufts Technology Services has been alerted to problems with Box, including file uploads & downloads, Box Sign and Box Notes. Further details available via the Box status page: https://status.box.com/
Posted Oct 02, 2023 - 13:31 EDT
This incident affected: Communication & Collaboration.