Power Outage Update: Ongoing Electrical and Meeting Room Impacts

Incident Report for Tufts University

Resolved

All issues are resolved and systems operational.
Posted Jul 03, 2025 - 09:05 EDT

Monitoring

Most of the Audio Visual spaces are operational at this time. We will continue to monitor.

If you encounter any issues, please report them to the TTS Help Desk by calling 617-627-3376 or emailing it@tufts.edu.
Posted Jul 02, 2025 - 09:58 EDT

Identified

Following yesterday’s power outage, some buildings continue to experience lingering issues due to power loss. Certain systems remain affected, and some meeting rooms and Zoom-enabled spaces are currently offline.

Electricians and AV staff are actively working to assess and resolve the situation.

If you encounter any issues, please report them to the TTS Help Desk by calling 617-627-3376 or emailing it@tufts.edu.
Posted Jul 01, 2025 - 09:22 EDT
This incident affected: Communication & Collaboration and Other.