Network Disruption at the Courts Residency
Incident Report for Tufts University
Resolved
All network services have been restored to 91/93/95 Professor's Row
Posted Mar 13, 2024 - 16:53 EDT
Investigating
TTS is aware of a loss of network connectivity to 93 and 95 Professors Row. Responsible staff have been dispatched to investigate further
Posted Mar 13, 2024 - 14:28 EDT
This incident affected: Network Services.