Snaplogic Outage: Impacts access from Kuali Build to SalesForce and Service Now

Incident Report for Tufts University

Resolved

The Snaplogic production issue has been resolved and all services are now operational.

Thank you for your patience.
Posted Feb 24, 2026 - 14:06 EST

Investigating

Snaplogic, our integration platform, is experiencing production issues resulting in slowness which may impact connections for our KualiBuild Service to SalesForce and ServiceNow.

This impacts any Kuali Build apps that generate a case on TechConnect or Salesforce. Here are some examples:

- Computer Request
- Sponsored Accounts
- Research Administration Support Request
- TSS HR Payroll-related Forms (e.g., Overpayments, PFLMA Timesheet, System Access Request)
- TSS Finance-related Forms (e.g., Purchase Card, Travel Authorization)

Once we have more information about a resolution, we will post an update here.
Posted Feb 23, 2026 - 12:45 EST
This incident affected: Financial Applications, HR Applications, Web Applications, and Other.