TTS has confirmed that the earlier cooling issues in one of our data centers have been resolved. If you continue to have trouble with any Tufts system, particularly wired/wireless networking, VDI, or Pay for Print, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Apr 30, 2026 - 14:21 EDT
Update
TTS is continuing to work with techs to mitigate the cooling issue in one of our data centers. Pay for Print remains unavailable. Other services should be restored. Next update: 2pm.
Posted Apr 30, 2026 - 12:08 EDT
Update
TTS has identified the cooling issue and is working with techs to mitigate them. Wired & wireless network issues should now be resolved, but other systems (including Pay for Print) remain unavailable. Next update: noon
If you are still having trouble with wireless or wired networks, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu
Posted Apr 30, 2026 - 10:50 EDT
Identified
TTS has identified the cooling issues in our data center and work is ongoing to remediate them. You may continue to experience issues with VDI, networking, and Pay for Print until the issues are resolved. Next update: 10:30
Posted Apr 30, 2026 - 09:06 EDT
Investigating
TTS has been made aware of cooling issues at one of our data centers that is affecting wired (ethernet) in Medford, VDI (Virtual Desktop), and other services. Next update: 9:00
Posted Apr 30, 2026 - 07:30 EDT
This incident affected: Student Technologies, Network Services, and Datacenter Services.