Microsoft Outlook issues

Incident Report for Tufts University

Resolved

The primary remediation has been deployed across the majority of impacted infrastructure and service availability remains stable above 99%.
Posted Sep 02, 2026 - 13:02 EDT

Update

Microsoft reports service availability remains stable above 99 percent and they expect the majority of users should no longer be seeing impact from this issue. Next update: 1:00 PM
Posted Sep 02, 2026 - 08:02 EDT

Update

Microsoft continues to monitor the deployment of the fix for any remaining pockets of impact before determining whether any additional corrective actions are required. They continue to investigate remaining reports of impact and evaluate additional actions to support full service recovery. Next update: Wednesday, September 2, 2026 at 8:00 AM.
Posted Sep 01, 2026 - 17:20 EDT

Update

Microsoft continues to monitor the deployment of the fix for any remaining pockets of impact before determining whether any additional corrective actions are required. They are investigating remaining reports of impact and evaluating additional actions to support full service recovery. Next update 5:00 PM.
Posted Sep 01, 2026 - 15:22 EDT

Update

Microsoft continues to monitor the deployment of the fix for any remaining pockets of impact before determining whether any additional corrective actions are required. Next update 3:00 PM.
Posted Sep 01, 2026 - 12:09 EDT

Update

Microsoft continues to monitor the deployment of the fix for any remaining pockets of impact before determining whether any additional corrective actions are required. Next update 12:00 PM.
Posted Sep 01, 2026 - 09:59 EDT

Monitoring

Microsoft reports they have deployed a fix. They are monitoring and will address remaining issues as they are identified. Next update: 10:00 AM.
Posted Sep 01, 2026 - 08:04 EDT

Update

Microsoft continues to investigate the widespread issues with their M365 platform, including (but not limited to) Microsoft Outlook. Next update: 9/1/2026 8:00 am
Posted Aug 31, 2026 - 19:56 EDT

Update

Microsoft continues to investigate the widespread issues with their M365 platform, including (but not limited to) Microsoft Outlook. Next update: 8:00 pm
Posted Aug 31, 2026 - 18:38 EDT

Update

Microsoft continues to investigate the widespread issues with their M365 platform, including (but not limited to) Microsoft Outlook. Next update: 6:30 pm
Posted Aug 31, 2026 - 17:04 EDT

Update

Microsoft continues to investigate the widespread issues with their M365 platform, including (but not limited to) Microsoft Outlook. Next update: 5:00 pm
Posted Aug 31, 2026 - 15:31 EDT

Update

Microsoft continues to investigate the widespread issues with their M365 platform, including (but not limited to) Microsoft Outlook. Next update: 3:30 pm
Posted Aug 31, 2026 - 14:42 EDT

Update

Microsoft continues to investigate the issues with its Outlook (Exchange) platform. This issue is not local to Tufts. Next update: 2:30 pm
Posted Aug 31, 2026 - 13:28 EDT

Investigating

TTS has been made aware of issues with Microsoft Outlook. Next update: 1:30 pm
Posted Aug 31, 2026 - 12:26 EDT
This incident affected: Email.