Student Information System (SIS) - ISSUE
Incident Report for Tufts University
Resolved
This incident has been resolved.
Posted 7 days ago. Nov 13, 2017 - 16:33 EST
Update
TTS is currently researching this issue, next update at 5pm.

If you are experiencing issues please contact the TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 7 days ago. Nov 13, 2017 - 16:02 EST
Investigating
Tufts is currently experiencing an issue with SIS. TTS is aware of the issue and is investigating. Next update at 4pm.

If you are experiencing issues please contact the TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 7 days ago. Nov 13, 2017 - 15:40 EST
This incident affected: Student Technologies.