CANVAS Service degraded
Incident Report for Tufts University
Resolved
The issues with the CANVAS system have been resolved and it is up and functioning well.
Posted Mar 25, 2021 - 13:08 EDT
Monitoring
This morning around 8:45 CANVAS experienced a brief outage for approximately 20 minutes. Service is being restored however we are noticing intermittent issues with long load times. We are working with the vendor and will update once things are resolved. Thanks for your patience while we work through this service disruption.
Posted Mar 25, 2021 - 09:51 EDT
This incident affected: Learning Management Systems.