Apptricity issues

Incident Report for Tufts University

Resolved

The issues that were occurring with Apptricity last week have been resolved. If you have any difficulty with Apptricity, please clear your cache and cookies. After that, if you continue to have trouble, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Jun 30, 2025 - 13:52 EDT

Investigating

Apptricity is having sporadic system issues due to high volume. Our Cloud vendor is investigating.
Posted Jun 25, 2025 - 12:07 EDT
This incident affected: Financial Applications.