Microsoft Online Services Degraded
Incident Report for Tufts University
Resolved
Microsoft has resolved the issue with their services.
Please see their status page for current information: https://status.azure.com/en-us/status
For details on the incident, please see the post regarding tracking ID LN01-P8Z: https://status.azure.com/en-us/status/history/
Posted Mar 16, 2021 - 07:22 EDT
Identified
Please see the following posting for the status Microsoft Online services.
https://status.azure.com/en-us/status
Posted Mar 15, 2021 - 17:18 EDT
Investigating
TTS is aware that Microsoft Online services are experiencing issues.
We are monitoring and will provide and update at 5:30.
Please check https://downdetector.com/ for specific services.
Posted Mar 15, 2021 - 17:01 EDT
This incident affected: Other.