Wireless (Wifi) service in Medford/Somerville
Incident Report for Tufts University
Resolved
The Medford wireless connection issues have been resolved. If you continue to have difficulty connecting to the Internet wirelessly in Medford, please contact the 24x7 IT Service Desk at 617-627-3376 or via email at it@tufts.edu.
Posted Oct 10, 2023 - 07:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results. If you continue to have difficulty connecting to the Internet wirelessly in Medford, please contact the 24x7 IT Service Desk at 617-627-3376 or via email at it@tufts.edu.
Posted Oct 06, 2023 - 07:47 EDT
Investigating
TTS is aware of wireless connection issues impacting a small percentage of users on the Medford/Somerville campus and is working with the vendor to address these issues. Users should contact the 24x7 TTS Service Desk at 617-627-3376 or it@tufts.edu for more information if they are experiencing issues.
Posted Oct 05, 2023 - 17:25 EDT
This incident affected: Network Services.