160 St Alphonsus St. - Power Outage | 7/26
Incident Report for Tufts University
Resolved
Power has now been restored and all network and wifi services are available.
Posted 3 months ago. Jul 26, 2018 - 13:44 EDT
Update
TTS is still actively monitoring the power outage affecting 160 St. Alphonsus St. (SMFA) only. Eversource crews are still on-site working to restore power. Next update will be when power has been returned.

Should there be any time sensitive questions / concerns, please reach out to the Tufts Technology Services.

Thanks,
(TTS) Service Desk
Email: it@tufts.edu
Phone: (617) 627 - 3376
Posted 3 months ago. Jul 26, 2018 - 12:42 EDT
Update
TTS is currently still monitoring power outage at 160 St. Alphonsus St. (SMFA) only. Eversource has a crew on-site working to restore power and has issued an ETA of between 11am - 12N. Will advise as to power restoral.

Should there be any time sensitive questions / concerns, please reach out to the Tufts Technology Services (TTS) Service Desk via email or phone: (617) 627 - 3376
Posted 3 months ago. Jul 26, 2018 - 09:25 EDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jul 26, 2018 - 07:06 EDT
Monitoring
TTS is aware of an on-going power outage at 160 St Alphonsus Street. Eversource, the utility power company, is on-site assessing/remedying the service outage. As soon as Eversource returns power, Tufts services / devices that rely on electrical power will return, too.

Next update: when electrical service is returned

Should there be any time sensitive questions / concerns, please reach out to the Tufts Technology Services (TTS) Service Desk via email or phone: (617) 627 - 3376
Posted 3 months ago. Jul 26, 2018 - 07:05 EDT
This incident affected: Network Services.