Gmail delivery issues
Incident Report for Tufts University
Resolved
Posted Dec 15, 2020 - 19:32 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 15, 2020 - 19:30 EST
Monitoring
We are continuing to monitor this issue. Please continue to review the status at:
https://downdetector.com/status/gmail/
https://www.google.com/appsstatus#hl=en&v=status
Posted Dec 15, 2020 - 18:16 EST
Identified
There are currently known issues with Gmail. The problem has been acknowledged and they are working resolve the problem. Please monitor the their status page at https://www.google.com/appsstatus#hl=en&v=status. Alternatively please monitor the status at https://downdetector.com/status/gmail/ .
Next update at 6PM.
Posted Dec 15, 2020 - 17:32 EST
This incident affected: Email.