Snaplogic Outage: Impacts access from Kuali Build to SalesForce and Service Now

Incident Report for Tufts University

Update

We continue to monitor the Snaplogic service and services that depend on it while the vendor continues to monitor and fix performance issues. We will update the community when there is a resolution. Thanks for your patience.
Posted Mar 05, 2026 - 16:09 EST

Update

Intermittent disruptions are possible for the remainder of today during vendor emergency maintenance to revert to a prior release with normal levels of stability expected. We will notify the community when things are resolved.
Posted Mar 03, 2026 - 15:17 EST

Monitoring

SnapLogic identified the issue and have implemented remediation actions to mitigate the impact.

The SnapLogic platform is currently stable and a permanent patch is in development and will be deployed shortly.

We are actively monitoring recovery progress and will provide further updates as improvements are completed.
Posted Mar 03, 2026 - 12:20 EST

Investigating

Snaplogic, our integration platform, is experiencing production issues resulting in slowness which may impact connections for our KualiBuild Service to SalesForce and ServiceNow.

This impacts any Kuali Build apps that generate a case on TechConnect or Salesforce. Here are some examples:

- Computer Request
- Sponsored Accounts
- Research Administration Support Request
- TSS HR Payroll-related Forms (e.g., Overpayments, PFLMA Timesheet, System Access Request)
- TSS Finance-related Forms (e.g., Purchase Card, Travel Authorization)

Once we have more information about a resolution, we will post an update here.
Posted Mar 03, 2026 - 10:06 EST
This incident affects: Financial Applications, HR Applications, Web Applications, and Other.