Box outage
Incident Report for Tufts University
Resolved
After further monitoring, the Box incident is now considered resolved. If you continue to have difficulty with Box, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Jan 09, 2024 - 16:45 EST
Monitoring
Box has announced that they have remediated this issue. If you continue to have trouble with Box (whether Box Drive or Box via the web), please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Jan 09, 2024 - 15:50 EST
Identified
Box has identified the issue and has begun remediation. Please see https://status.box.com/ for more details.

Next update: 4:00 p.m. or earlier.
Posted Jan 09, 2024 - 14:56 EST
Investigating
Tufts Technology Services has been made aware of an issue with Box, specifically Box Drive. Further information can be found on the Box status page: https://status.box.com/

Next update: 3:00 p.m.
Posted Jan 09, 2024 - 14:29 EST
This incident affected: Communication & Collaboration.