Box.com
Incident Report for Tufts University
Resolved
All Box Services have returned to an operational state.
If there are issues, please contact TTS Service Desk.
Call: 617-627-3376
Email: it@tufts.edu
Posted Sep 12, 2019 - 16:19 EDT
Monitoring
Update from Box: We are starting to see recovery of Box Services including the ability to access the Box web application, Box Sync, Box Drive, Box mobile application and API. Our teams remain actively engaged to validate full remediation.
https://status.box.com/
Posted Sep 12, 2019 - 13:38 EDT
Investigating
We are currently investigating an issue with Box services. We will provide more information as it becomes available.
Posted Sep 12, 2019 - 12:13 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.